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Image properties and edit tools
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Channel Color Assignment

BITPLANE

an Oxfor nts company

Under the File menu, choose Preferences, choose Loading

e Default Colors — Colors are
always assigned as defined
here.

o File Colors — Colors are loaded
based on a look up table found
in the image file.

 Emission Wavelength — If this
parameter is reported in the
image file, a color is matched to
this wavelength

% Preferences

System
Display
Loading
Calculation
Time

Surpass
Creation Parameters
Vantage Plots
Statistics
CustomTools
Licenses
Update
Usage Data
3D Cursor
Annotate
Advanced

Loading
How should colors be assigned when loading from other than Imaris data formats?
Take Colors from
*) Default Colors

@ File Colors (color table or base color if available, otherwise default colors)

Emission Wavelength (from file if available, otherwise default colors)

Default Colors

iQ ImageDisk File

(Could not autodetect an iQ ImageDisk)

e
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Image Properties: Geometry BITPLANE

an Oxfor nents company

Ctrl + 1

Under the Edit menu, choose Image Properties, choose Geometry

For supported file types, 2 image Peperies R e
Imaris will load the correct —
voxel size and time B g —

stamps automatically EEE —

Step sizes of “1.0” should Coordinates

be verified, as this is the e ECEER TR T ‘

1 Date [yyyy-mm-dd]
: Min: 0 38.307 -0.145 20090723 |+
Imaris default value
Max: 75.344 105.397 7.415 Time [hh:mm:ss.sss]
) 07:07:50.000 |%

/ All Equidistant...

e X,Y, ZVoxel Sizes
 Voxel Units

* Number of Time Points
« Time Stamps
«“All Equidistant” to set manually

» Data Type (8 bit, 16 bit, 32 bit) o ] [Ccance ]

e OXFORD
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Image Properties: Data Set BITPLANE

its company

Ctrl +1 Under the Edit menu, choose Image Properties, click Data Set

All Image Types ot

* Numerical Aperture (N.A.) i Nome:  zatacka

Channel 2 Desciption: (description not specified)

Channel 3
Thumbnail
Parameters

Imaris Files Only
 Data Set Name
» Description

Lens Power:

b Log - Of I marls I mage Numerical Aperture (N.A.): not known
Processing functions =
i i <bpCrop3DCommand actorname = "" actorid = "0" lowX = "0" lowY = "181" lowZ = "0" highX
ap pI I ed to th e I m ag e <bplpContrastStretchCommand actoername = "" actorid = "0" minsrc = "713.000 1838.000 2144

Data set name and description

must be manually entered. Z »
[ OK ][ Cancel ]
e OXFORD
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Image Properties: Channel

nts company

Ctrl + |

Under the Edit menu, choose Image Properties, click Channel X

All image files (if present) e
e Channel Name ok, one: ot
« Emission Wavelength g T
« Excitation Wavelength e

e Pinhole Radius

Emission Wavelength: 583
Exdtation Wavelength: 558

Pinhole Radius:

Imaris Files Only

« Description of the channel o R -
4
Red:  0.000
Blue:  0.000
Channel description must
be manually entered.
R 2 n~s>v<-thms@Q I
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Image Properties: Thumbnail BITPLANE

Ctrl + | Under the Edit menu, choose Image Properties, click Thumbnail

Imaris will create a thumbnail for the

Windows Explorer based on your Geometry
. Data Set Type
SeleCtlon here: ‘4 Chaz:::nell (7) None () Middle Slice @ MIP (7) Blend
Channel 2 Preview
Channel 3
° N O n e Thumbnail

Parameters

* Middle Slice (Time Point 1)

MIP (Maximum Intensity
Projection)

» Blend (Blending Projection with

lighting))

MIP and Blend options are the images
produced in the Easy 3D view.

[ ok ][ cancel ]

. R
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Image Properties: Parameters BITPLACONF,EY

Ctrl + | Under the Edit menu, choose Image Properties, click Parameters
— -  TT———————SDSSe————
Geometry
Data Set 0.000 1.000 0.000
4 Channels
. . Channel1 Parameter Value A Add Group...

* Imaris searches the file header Channei2 4 Channel0
. . Channel 3 Color 0.000 1.000 0.000 |
information to extract as much Thumbnai ColorMode BaseColor

. Parameters ColorOpacity 1.000
metadata as pOSSIbIe. ColorRange 228358 162,388 gl
ExposureValue 37.500
GammaCorrection 1.000
. . LSMEmissionWavelength 583
« Values found are placed into this LSMeciaiontavelength 558
LSMPhotons 1
table. LSMPinhole
NumericalAperture 1.200
Objective C-Apochromat 63x/1.20 W Korr U...
4 Channell
» The values reported depend on Color 000000001000
. ColorMode BaseColor
the file format. ColorOpacity 1000
ColorRange 72.2716158.038
ExposureValue 680.320
GammaCorrection 1.000
LSMEmissionWavelength 461
LSMExcitationWavelength 359
LSMPhotons 1
LSMPinhole
NumericalAperture 1.200
Objective C-Apochromat 63x/1.20 W Korr U...
4 Channel 2
Color 1.000 0.000 0.000 =
)
[ OK ] [ Cancel ]
e lNSllt‘;ME@Q I

© Oxford Instruments 2016



BITPLANE

an Oxford Instruments company

Adding to or Deleting from a loaded data set

Under the Edit menu

* Add time points — adds time points to the end e o
of an open data set (x,y,z, # of color channels Redo Ctrl+Y
and data type must be the same) Copy Snapshot Image Ctri+C
Image Properties... Ctrl+1
Show Display Adjust t Ctrl+D
« Add channels — adds a channel to an open e e
== Annotate Ctrl+Shift+P
data set (x,y,z, t, and data type must be the o
—  Add Time Points...
Same)| Delete Time Points...
Add Channels... Ctrl+Shift+A
« Add slices — adds z layers to the end of an o el e
open data set (x,y, t and data type must be the Delete Slices..
sam e)| Crop Time...
Resample Time...
. . . Crop 3D... Ctrl+W
 Delete Time Points / Channels / Slices - Resample 3D..
removes the appropriate component from the Sl i
open dataset
. xR0
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Cropping a loaded data set BITPLANE

company

Under the Edit menu, choose Crop 3D

 See MIP image in xz, and yz view
as well as xy

» Can zoom (center mouse) and pan
(right mouse) in image.

» Choose selection by entering
numbers or moving box in image

 Disadvantage — data is already
loaded in memory... If dataset
size is the problem, “Resampling
Open” is more efficient

Select Crop Dimensions

From: To: Size:

; w% || At |
X: 2 = 214 S 143
Y: 56 = 164 4 109
z 1 B 64 %] (64
Time
0 :]

e
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Huge Data Capable

Imaris can read and visualize at least 50 GB (single
frame!) multi-everything image.

Imaris 5.5 (2006) was the first version of Imaris to
support “huge images”. This enables users to load,
process, and visualize images that are far larger than
the available computer memory (RAM).

Imaris will speed up processing of large images by only
loading parts of the image that are visible to the user
or required by an image processing operation.

Imaris 6.3 (2009) introduced a technical feature which
makes the zooming and panning much faster and
smoother on such large images.

Saving files in version 8.2 is significantly faster (up to a
factor of 5) than previous versions due to multithreaded
gzip compression of image data.

BITPLANE
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Imaris File Converter BITPLANE

= Batch conversion of extremely large Arena Tab active

files to Imaris 5.5 file format allows
near-instant loading into Imaris

File menu

= Runs independently of Imaris > [P Batch Convert ‘

= Does not require an Imaris license

= Import Options B Tonavis e Convariee - PS>
—A. Drag and Drop o Qs
qu&t:vctioﬂes.mdda&:!tmbebw © Same Folder as Input File
H - to add Fies.
—B. Click Add Files Spectic Folder:
 Add Fies... Format: |Baplane: Imars 5.5 (*.ms) v | [ settings...
= Select the output directory v o Selected Input e
_ * EflmarisFileConverterTest/2spot2.czi | « E/ImarisFileConverterTest/2 spot2_1.ims -
A. Source « E/ImansFileConverterTest/Leice_sene3.lif « E/lmansFdeConverterTest/Leica_sene3ams
_B Common Directo ry « E/ImarisFileConverterTest/R18TiffSesies/R18Demo_T00_2000.tif  + E:/ImarisFileConverterTest/RISTifSeries/Ri8Demo_T0...
Preferences... About... Clear Sedected | | Clear Al | Start
@ IN s>v<lE1 M (@ I

© Oxford Instruments 2016



itplane made the IMS file format Open Source BITPLANE
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IMARIS 5.5 File Format Description (IMS)

0. Introduction

The Imaris File Format is designed to allow fast visualization of very large images. For this purpose it stores not only the original
image data but also lower resolution versions of the original data. This allows the visualization software to load only low resolution
data when those are sufficient. Also for the purpose of fast visualization the Imaris File Format stores the image data in contiguous
3D chunks (hdf-terminology for 3D blocks) which allows the visualization software to load only those data that are in the field of
view. The multiresolution structure and the chunk-wise storage layout are the comnerstones of this high performance file format.

1. Summary

The file format is based on the standard HDF5 (Hierarchical Data Format 5) developed by The National Center for Supercomputing
Applications, University of lllinois at Urbana-Champaign. This allows the use of widely available HDF5 libraries and tools.

An Imaris 5.5 file consists of three main types of groups (or folders) for the image:

DataSet: The image itself (includes all slices, channels, and time points, resolution levels)
DataSetinfo: Image metadata information (e.g. voxel size)
Thumbnail: 2D thumbnail of the image.

An additional group may contain the Imaris Scene:
Scene or Scene8: surpass objects, annotations, etc.

In this document, the terms group, attribute and dataset refer to the concepts given in the HDF5 documentation. Whenever a path
is given (/DataSet/ResolutionLevel 12) one should open the corresponding groups and subgroups.

The prior “Imaris Classic” and ‘Imaris3” file formats are not based on the HDF5
specifications and will not be described in this document.

{®] retina.ims
¢ @ DataSet
¢ @ ResolutionLevel 0
¢ @ TimePoint 0
¢~ @ Channel 0

2. Tools and Resources

Bitplane uses the HDF5 library from the HDF Group as a backend for reading and writing
HDFS5 files. A good starting point for reading about the HDF5 file format is the website of the
HDF5 Group, http://iwww.hdfgroup.org/HDF5/. The HDF Group provides its library as open
source and free of charge. It is recommended to make use of the library rather than creating

your own HDF5 reader/writer. i Histogram
¢ @ Channel 1
The HDF Group also provides helpful tools along with the library. Noteworthy is HDFView, a @ Dat
ata

Java-based HDF file inspector. It can be downloaded free of charge here.

It is highly recommended to use HDFView to look at some example IMS files in order to gain

¢ @ ResolutionLevel 1
an understanding of the file format.

¢ @ TimePoint 0
o~ 4 Channel 0
o~ 4 Channel 1
o= ) ResolutionLevel 2
o~ €) DataSetinfo
o ) Thumbnail

3. Structure

The Imaris 5.5 file structure is composed of a root “folder” and three main groups, DataSet,
DataSetInfo, and Thumbnail.

The screenshot on the right of an IMS file in HDFView shows the HDF file structure. The
example image has two channels and 3 resolution levels.

The DataSet folder contains the actual image data. The DataSetinfo folder contains descriptive parameters. The Thumbnail folder
contains a 2D thumbnail of the image

Full description:

http://open.bitplane.com/Default.aspx?tabid=268

4. Data

The multiresolution structure and the chunk-wise storage layout are the cornerstones of this high performance file format.

4.1 Chunk Size

For efficient data access for visualization the Imaris 5.5 file format stores image data in 3D chunks. Typical chunk sizes are
128x128x64 or 256x256x16. The optimal chunk size is determined by the geometry of the image and it is not easy to specify rules
for reproducing exactly the chunk sizes that Imaris will write into the hdf-file. It is also not necessary because the hdf library is very
efficient at reading data as long as the layout is not entirely different. If you want to write image files for Imaris to read, try to create
3D chunks that are of roughly 1 Megabyte size. This will produce good results for rendering in Imaris. If you need to tweak

performance, please contact the Bitplane engineering team to get more detailed information.

4.2 Resolution levels

For efficient visualization the Imaris 5.5 file format stores not only the original data but also low resolution versions of the original

data. The number of resolution levels in the file is determined by the following pseudocode:

void getMultiResolutionPyramidalSizes( const size_t[3] aDataSize,
st vectoré aResolutionSizes

const flcat mMinVolumeSizeMB = 1.f;
aResolutionSizes.clear();
size_t[3] vNewResolution = aDataSize;

float vVolumeMB;

do {

vResolutionSizes.push_back(vNewResolution);

size_t[3] vLastResclution = vNewResolution;

stResolution[0] * vLastResclution[l] * vLastResolution[2];
++d) {

= 0;

vNewResolution[d] = vLastResclution(d] / 2;
else
vNewResolution[d] = vLastRescluticn(d];

// make sure we don't have zero-size dimension
vNewResolutionld] =
}

max((size_t)1l, vNewResolution[d]);

VolumeMB = vNewResolution[0] ¢ vNewResolution[l] ¢ vNewReso

lumeMB > mMinVolumeSizeMB);

ion[2]1) / (1024.f *

0*vLastResolution[d]) * (1l0*vLastResolution[d])} > vLastVolume / vLastResclution(d])

1024.£);
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